Browser minimum requirements

Compatibility:IdSurvey 5IdSurvey 6

Minimum requirements to correctly use IdSurvey are: an Internet connection and a common Windows or OSX browser. We recommend using the latest version of your preferred browser.

Web-browsers supported: Mozilla Firefox, Google Chrome, Apple Safari or Internet Explorer. Each one of these can be downloaded for free. Older versions are still supported but not recommended as they could cause display or functional issues.

Please note: for Internet Explorer only, the minimum required version is 9.

Leave A Comment?